Change workflow subclass/descriptor type from CWL to WDL

I accidentally added a .dockstore.yml file to my GitHub repo with the wrong subclass (CWL instead of WDL). I tried changing the subclass to WDL in .dockstore.yml, but it didn’t update in the dockstore interface and I can’t publish the workflow.

If it helps, here are links to my repository and the dockstore workflow page.

How can I change the subclass/descriptor type from CWL to WDL?

Try changing the name at the same time you change the subclass to WDL.
That should create a new WDL workflow.

We also have a new version of Dockstore coming out in less than a month that will let you delete workflows in this situation (never been published) but the current workaround would be to create a new one with the right info.

Let us know if it works!

I tried changing the name in the .dockstore.yml file from “fetch_dbgap_files” to “fetch_dbgap_files_wdl”, but the new workflow hasn’t shown up on Dockstore after ~15 minutes. Here’s the contents of my .dockstore.yml file:

version: 1.2
    - name: fetch_dbgap_files_wdl
      subclass: WDL
      primaryDescriptorPath: fetch_dbgap_files.wdl

Also, noting that the ability to delete unpublished workflows will be great, so thanks for implementing that feature!

Hmmm, does anything interesting show up in the github app logs?
Here’s a link to how you can find them GitHub App Troubleshooting & FAQs — Dockstore documentation

No, nothing in the github app logs. The last thing I see is yesterday’s error saying that I can’d add a WDL version to a CWL workflow.

I’ve also created Update .dockstore.yml by denis-yuen · Pull Request #1 · UW-GAC/fetch-dbgap-files · GitHub to address one possible issue

Edit to add: this does seem to work on my (unpublished) fork

Thanks for the pull request – I merged it in. I’m still not seeing any new unpublished workflows on my Dockstore page though. I tried refreshing the github organization a couple times. Still nothing new in the app logs.

Hmmm, oddly, I don’t see any events at all on the back-end either.

Could you do something trivial for the repo contents such as modifying a readme? I wonder if the PR merge somehow doesn’t count as an event since the origin is my fork.

Ah, I figured it out. First, I made a small change to the README and nothing happened. Then I looked at which repositories were being synched with Dockstore. As part of my previous attempts to change CWL to WDL yesterday, I had de-selected the fetch-dbgap-files repo so nothing from it was synching. I re-selected it and now the workflow has synched successfully. Thanks!

1 Like