Dockstore unable to read .yml from Github respository?

I am trying to understand the error I’m getting. I confirmed that the .yml file is in the correct format and it’s in the main directory. Does the error mean Dockstore can’t find it or that when it finds the file it can’t read it? Or something else?



Thank you for reaching out.
I checked your repository and it looks like the .yml file is named yml_file.dockstore.yml. Renaming the file to .dockstore.yml should fix your problem.

Please let us know if it works!

Nayeon - Dockstore


Yes, that worked, thanks, but now I am unable to publish the workflow due to not having a valid descriptor file? Is the path wrong in my .yml file?

(sorry, I didn’t write any of this except the .yml file, I’m just trying to use the workflow on Terra, which only allows me to add it through the Dockstore)


I see that the primary descriptor path was wrong in the screenshot but it looks fixed now on your GitHub.

Are you still having this issue?

Nayeon - Dockstore

Once I changed the path it worked to add the .wdl files but the main one is still invalid.


I believe the error is because your /hBOTA.wdl workflow has an https import that is not returning the raw content of the workflow it’s trying to import. WDL 1.0 specs say that the contents of the document in each URI must be WDL source code.

On line 2 of your hBota.wdl workflow, try changing the URL to and wait a couple minutes for Dockstore to sync the change. Check your GitHub App logs again and verify that there are no errors in the most recent push event.

Let me know how that goes!


I changed the directory to point to that URL and that allowed me to publish the workflow. Thank you.

The workflow itself cannot be imported to Terra.Bio still (Disallowed URI) so I don’t think it actually works but I should probably create a separate post for that if I can’t figure it out…